PierceOnLine(MOODLE) is supported by current versions of Internet Explorer, Mozilla Firefox, Google Chrome and Apple Safari. 
Whichever web browser is used, JavaScript needs to be enabled. 

PierceOnLine utilizes several web technologies to deliver engaging course content to enhance the learning experience of students. Some of the technologies employed require that common web browser plug-ins be installed and enabled. 

The following browser plug-ins are required or recommended:
  Adobe Flash Player – Required
  Apple Quicktime – Recommended
  Adobe Reader - Recommended
  Java – Recommended
You can click on the links above to learn more or download any missing or outdated plug-ins for free.
Last modified: Monday, 18 June 2012, 11:31 PM